Internet Explorer Users

If you are using an out of date Internet Explorer version -i.e. 7 or older- it is likely you will not be able to view the map properly. The map works perfectly with the following browsers, which are safer, faster and better than Internet Explorer, so I would recommend downloading and installing at least one of them so you can enjoy the map and many other websites. If you click on the name of each browser it will take you to its website so you can download them. Most of them are available for various OS (Windows, Linux. Mac,...) and languages.

Another option is minimising and maximising the window, but it will only work with certain versions of Internet Explorer

Internet Explorer

Mozilla Firefox

Google Chrome

Safari